Problem Uploading Photos

You're on Page 2 of 8
Go to
  • problem copying photo
    hello, same here. I tried few times with different pictures. please help!
  • Hi,
    I have the same problem. I did make sure that photos I tried to upload comply with all rules. I resized photos to a different sizes, but nothing helped
  • I've the same problem too
  • Hi everyone.

    I will raise the issue with the tech team and see what they say.

  • I have the same problem too. I've tried yesterday and today and it always says "problem copying photo" and I have stuck to the guidelines.
  • Michael, has this problem been resolved? I noticed you have not uploaded any photos, which may indicate you cannot overcome the problem.
  • Same problem here, I am trying to post my first one and I always get the "Problem copying photo." note
  • Hello,

    Is this problem still occurring for anyone? And have you tried using a different browser (Firefox, Chrome)?

    Thank you,

  • I am using Flock browser and I have the very same problem. I'll try some other browser and see if it works.

    EDIT: just tried Firefox, same thing...
  • I have brought this to the attention of the tech team.


error, not working, problem, questions, trouble