Forums


Go Back   The TrekEarth Forums >

Notices

Reply
 
Thread Tools
  #1  
Old 05-21-2009, 12:36 AM
kajenn's Avatar
kajenn kajenn is offline
TE Senior Member
Thread Starter
 
Join Date: Nov 2003
Location: Lund, Sweden
Posts: 699
Default How many did contribute...?

Seeing the amount of reactions on the new design of the TrekEarth sites - and especially not finding it too attractive myself - I can't help wondering how could it go so wrong? How many did actually contribute in the testing of the beta site?

And I mean really contribute; i.e. sending an email to the correct recipient at TrekEarth, as requested, and not just some rumblings of discontent on the General Forum, which probably never got noticed by the "design team".

On a personal level I reported three problems/glitches and as far as I see, they're dealt with. As for the general design - an flaws therein - I leave that to those with a better knowledge than myself.
Reply With Quote
  #2  
Old 05-21-2009, 12:54 AM
Colombiana's Avatar
Colombiana Colombiana is offline
TE Junior Member
 
Join Date: Aug 2007
Posts: 238
Default Re: How many did contribute...?

I don't like the fact that you can't read comments or even reply to them. Other than that, I will get used to it.
Reply With Quote
  #3  
Old 05-21-2009, 04:26 AM
stego's Avatar
stego stego is offline
TE Expert
 
Join Date: Sep 2006
Posts: 2,495
Default Re: How many did contribute...?

I contributed by posting in the beta forum and by sending emails to the bug reporting account.

While I applaud the intention of improving appearance, I really don't understand why the new site has less features than the new one and not a single new useful feature. And no matter I force myself to use the new site, something I have been doing since the beta was announced, I still find the old one much more usable.

Regards,
Josť
Reply With Quote
  #4  
Old 05-21-2009, 04:40 AM
bibiweb's Avatar
bibiweb bibiweb is offline
TE Expert
 
Join Date: Jul 2004
Posts: 4,756
Default Re: How many did contribute...?

Hi Kaj,

Until yesterday's "Go Live", the BetaTalk forum was full of reactions, not only negative ones, but also many constructive remarks concerning glitches, navigation issues and missing features. I also sent private emails to the person(s) directly concerned with the implementation of the new site and I'm quite certain that I wasn't the only one.

Of course technical bugs have been corrected an are being handled in priority since yesterday's cut over, but regarding all the other remarks and suggestions I have the impression that most of these seem to have been ignored for the time being. We can only hope that they will be considered once the major start-up related issues are resolved.

It's nice to see that overall performance seems better now than 10 hours ago... though I still can't upload a photo. :o(

Bibi
Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 04:58 AM.



Copyright © 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.
explore TREKEARTH